• Fallunterscheidung bei Tabellenkalkulationen
  • verybusybeaver
  • 07.03.2021
  • Informatik
  • 10
Um die Lizenzinformationen zu sehen, klicken Sie bitte den gewünschten Inhalt an.
  • Um auf Zwischenergebnisse oder Nutzereingaben reagieren zu können, gibt es in Tabellenkalkulationsprogrammen immer eine Möglichkeit, auf verschiedene, vordefinierte Fälle mit vorbereiteten Ausgabewerten zu reagieren. In Excel wird diese Funktion mit dem Schlüsselwort "WENN" aufgerufen und folgt allgemein dem folgenden Schema:

    WENN... DANN... SONST...

    Dabei ist WENN das Schlüsselwort, mit dem die Funktion eingeleitet wird. Der Funktion werden dann drei Parameter übergeben, so dass sich folgende Grundgestalt ergibt:

    =WENN([Wahrheitstest]; [DANN-Wert / Wert_wenn_wahr]; [SONST-Wert / Wert_wenn_falsch])

    Dabei ist der Wahrheitstest eine Aussage, die zu einem Wahrheitswert ausgewertet wird (oder direkt ein Wahrheitswert). Kommt beim Wahrheitstest "WAHR" heraus, wird der als "DANN-Wert" festgelegte Wert ausgegeben, kommt "FALSCH" heraus, der "SONST-Wert".

    Andere Ergebnisse außer WAHR und FALSCH sind nicht möglich, da sich jede (einzelne) Aussage entweder wahr oder falsch, aber nicht beides oder etwas anderes sein kann. Ist die Aussage nicht wahr, ist sie falsch.

    Beispiel

    =WENN(A1=1;"ja";"nein")\gdef\cloze#1{\colorbox{none}{\color{transparent}{\large{$\displaystyle #1$}}}} =WENN(A1=1; "ja"; "nein")

    Die zu testende Aussage lautet, dass in Zelle A1 der Wert 1 gespeichert sein soll. Wenn das der Fall ist, wird die Aussage zu "WAHR" ausgewertet und der DANN-Wert (also "ja") ausgegeben. Ist das nicht der Fall, wird sie zu FALSCH ausgewertet und der SONST-Wert (also "nein") ausgegeben.

    Beachte

    Der Inhalt von DANN- und SONST-Wert geht in den Wahrheitstest nicht ein - es wäre also auch möglich, widersprüchliche Antworten auszugeben, also etwa "ungerade", obwohl in der untersuchten Zelle eine gerade Zahl gespeichert ist. Entscheidend ist NUR der Wahrheitstest!

    Beachte außerdem, dass Text in Anführungszeichen gesetzt werden muss, sowohl im Wahrheitstest als auch beim DANN-/Sonst-Wert!

    Übrigens: Alle Funktionen können, sofern die Ausgabewerte den richtigen Datentyp besitzen, ineinander geschachtelt werden, also z.B. indem zwei WENN-Funktionen kombiniert werden:

    =WENN(A1=1;"ja";WENN(A1=2;"ja";"nein"))\gdef\cloze#1{\colorbox{none}{\color{transparent}{\large{$\displaystyle #1$}}}} =WENN(A1=1; "ja";WENN(A1=2;"ja";"nein"))